【復旧済み】2026年6月18日 HireRoo API 証明書期限切れによるアクセス障害に関するご報告

メンテナンス・障害情報

HireRoo API 証明書期限切れによるアクセス障害に関するご報告

概要

2026年6月17日(水)23:32頃から2026年6月18日(木)9:18頃まで、HireRoo の一部画面で読み込みが完了しない、または操作を完了できない状態が発生しておりました。

本障害により、当該時間帯に HireRoo をご利用いただいた企業ユーザー様および候補者様に影響があった可能性があります。

ご不便とご迷惑をおかけしましたことを、深くお詫び申し上げます。

発生日時

  • 発生時刻: 2026年6月17日(水)23:32頃
  • 復旧時刻: 2026年6月18日(木)9:18頃
  • 影響時間: 約9時間45分

影響範囲

  • HireRoo の企業向け画面
  • HireRoo の候補者向け画面

当該時間帯にアクセスされた場合、画面が Loading のまま進まない、ログイン後のデータ取得が完了しない、または一部の操作が失敗する状態となっていた可能性があります。

原因

HireRoo の API 通信を受け付けるドメインの TLS 証明書が期限切れとなっていました。

証明書の自動更新は事前に開始されていましたが、証明書発行設定の一部が特定用途向けに変更されていたため、HireRoo 本体 API 向けのワイルドカード証明書が正常に更新されない状態となっていました。

その結果、HireRoo の画面から API への通信がブラウザによりブロックされ、一部画面の読み込みや操作が正常に処理できない状態が発生しました。

対応内容

証明書発行設定を修正し、対象証明書の再発行を手動で実行しました。

その後、新しい証明書が配信されていること、および API エンドポイントへの TLS 接続が正常に検証できることを確認し、9:18頃に復旧完了と判断しました。

再発防止策

同様の事象を防ぐため、以下の対応を進めます。

  • 本番 API 証明書の期限監視とアラートを追加します。
  • 証明書管理システムで更新待ちまたは失敗状態が継続した場合に検知できるよう、監視を強化します。
  • 証明書発行設定を変更する際に、既存ドメインの更新可否を事前確認する手順を追加します。
  • 今回の修正をコード管理された設定へ反映し、再適用時に設定が戻らないようにします。

現在の状況

現在は復旧しており、HireRoo は通常どおりご利用いただけます。